## Upgrade Algorand Indexer 2.10.0 along with Algorand 3.5.1

The archival node is necessary for normal indexer operation, so I wouldn’t disable archival mode or shut down the node. The config you mention appears to be for the algod node, so I would leave that as is. Indexer can be started and pointed to the archival node to catch up. The version of indexer is...

---

## Indexer error: overflowed subtracting rewards for block

Hmm, unfortunately I think this is broken, because the database seems to be in an inconsistent state. For data integrity I’d unfortunately recommend re-indexing, because the block evaluator is getting a different answer on the indexer side.

---

## Upgrade Algorand Indexer 2.10.0 along with Algorand 3.5.1

Unfortunately, by restarting indexer, I wonder if you cancelled the database transaction and had to start over. A mainnet indexer upgrade using an db.r5.xlarge instance took about a half hour, so ten hours sounds long. What sort of hardware are you using? Is there anything interesting reported if ...

---

## Fast Catchup not working for our node on MainNet

We adjusted relay records to remove some that were showing errors at the end of the month, so I would be interested to hear if this is still an issue for people.

---

## MainNet and TestNet Upgrade: v2.1.3

There is a one time accounts db migration that will take a few minutes. It should start up normally once this is complete.

---

## Binaries for 2.0.8 (the current latest release) missing

Thanks for the heads up - we’ve restored these. Sorry for the inconvenience!
